BBO Discussion Forums: New BBO won't load in Safari - BBO Discussion Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

New BBO won't load in Safari

#1 User is offline   Fidel0 

  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 2019-August-02

Posted 2019-August-02, 04:57

Hello, I'm in OSX 10.10 yosemite, and Safari 8.0

yesterday was the day that some kind of automatic switch to this new version I wasn't aware of, occurred,
and, as a result, it made playing @ BBO under Safari no longer possible.
I can still see the login / register screen, in all its colorful options,
but when I hit login, i quickly transition from a cream-ish background screen with a big BBO logo,
to just that cream background in milliseconds, a final screen where nothing can be seen,
absolutely zero features, the screen is void, its mere ocean of background plain color.

Have tried several options, even resetting Safari to factory settings from the Command Line,
not merely wiping out cookies, caches and websites' data, I mean, everything, leaving safari in a restart
with its welcome page and no websites data of any kind.

To no avail. i can no longer see anything under this HTML5 version.

i can, in either Firefox and Chrome, but Safari remains impregnable now to BBO...

is there a way around to fix this?

tenks
0

#2 User is offline   barmar 

  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Group: Admin
  • Posts: 20,826
  • Joined: 2004-August-21
  • Gender:Male

Posted 2019-August-02, 08:38

It works in newer versions of Safari, but Safari 8.0 gets an error. We'll look into it.

#3 User is offline   barmar 

  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Group: Admin
  • Posts: 20,826
  • Joined: 2004-August-21
  • Gender:Male

Posted 2019-August-02, 09:38

According to Wikipedia, the latest Safari version for Yosemite is 10.1.2, and that's what we have on our Yosemite configuration. Is there a reason you're running such an old version of Safari? Try getting an upgrade from the App Store.

#4 User is offline   phil7 

  • Pip
  • Group: Members
  • Posts: 3
  • Joined: 2019-August-07

Posted 2019-August-07, 16:22

Hi,
I'm having the same problem with Microsoft Edge, the login button leads to the cream screen and goes no further
Phil
0

#5 User is offline   barmar 

  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Group: Admin
  • Posts: 20,826
  • Joined: 2004-August-21
  • Gender:Male

Posted 2019-August-08, 09:35

View Postphil7, on 2019-August-07, 16:22, said:

Hi,
I'm having the same problem with Microsoft Edge, the login button leads to the cream screen and goes no further
Phil

I can't reproduce this problem. I tried both Edge 15 and 18 using BrowserStack's testing service.

Press F12 to open Developer Tools, switch to the Console tab, select "Errors", and post what you see.

#6 User is offline   Fidel0 

  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 2019-August-02

Posted 2021-September-30, 10:24

this hasn't been solved yet despite Admin said two years ago he's look into it.


View Postbarmar, on 2019-August-02, 09:38, said:

According to Wikipedia, the latest Safari version for Yosemite is 10.1.2, and that's what we have on our Yosemite configuration. Is there a reason you're running such an old version of Safari? Try getting an upgrade from the App Store.



And to answer his qwuestion, SAFARI Versión 10.1.2 (10603.3.8) is old,
but it is also the latest version that is possible to instakll in Yosemite 10.10,
which means I CAN'T INSTALL A NEWER, BETTER ONE, while miy Mini Mac would run
smoothly with a newer Mac OSx either,. Yosemite runs OK AND I DON'T WANT TO CHANGE IT
(nor I'd be very proficient6 in doing so).



this update reply is to report that, moreover the SAFARI 10.1 issue not being resolved yet,
today I've lost also the possiblity of LOGIN IN through CHROME Versión 87.0.4280.88 (Build oficial) (x86_64).

the message I obtain now there is the same as SAFARI's: "COULD NOT LOAN CRITICAL FILE. PLEASE CHECK YOUR INTERNET COONECTION AND TRY AGAIN"
which obviously, will not wrok, trying again, forever more.

First, or prior to that message, comes this Browser's BLOCK,
(which I must circunvent through an "Advanced Configuration" button below the actual message, in order to get thus rejected:

"

La conexión no es privada
Es posible que los atacantes estén intentando robar tu información de www.bridgebase.com (por ejemplo, contraseñas, mensajes o tarjetas de crédito). Más información
NET::ERR_CERT_DATE_INVALID

"


would it be possible, PLEASE, to finally give support to both browsers in Mac OSx 10.10?
NOW I'M FORCED TO LOGIN THROUGH MOZILLA FIREFOX Version Firefox 78.9.0esr.dmg which is also quite old, fort Firefox.

If I ever lose this third option, i'm gong to be in really real trouble to continue playing @ bridgebase online...

thanks, Admin.
0

#7 User is offline   barmar 

  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Group: Admin
  • Posts: 20,826
  • Joined: 2004-August-21
  • Gender:Male

Posted 2021-October-04, 08:20

Let's Encrypt expired one of their security certificates on September 30, and old versions of MacOS rely on this certificate. This cuts them off from many web sites that use Let's Encrypt.

#8 User is offline   crissanti 

  • Pip
  • Group: Members
  • Posts: 1
  • Joined: 2021-October-04

Posted 2021-October-04, 13:06

but is there a way out of this?
how do I get around this issue?
0

#9 User is offline   mycroft 

  • Secretary Bird
  • PipPipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 6,125
  • Joined: 2003-July-12
  • Gender:Male
  • Location:Calgary, Canada

Posted 2021-October-04, 13:29

Apple should be coming out with a fix for this sometime - no idea on how far back they'll fix it, though, so you might need an OS update (which might not be possible on your device. Yell at Apple, maybe if enough people do it they'll fix farther back). Debian, RedHat, and FreeBSD have already done so for those systems that use the bad SSL library, but you have to update them manually (or let it autoupdate on whatever schedule you've set up).

A workaround is to use Firefox, as it maintains its own certificate store.
When I go to sea, don't fear for me, Fear For The Storm -- Birdie and the Swansong (tSCoSI)
0

#10 User is offline   barmar 

  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Group: Admin
  • Posts: 20,826
  • Joined: 2004-August-21
  • Gender:Male

Posted 2021-October-08, 13:07

View Postmycroft, on 2021-October-04, 13:29, said:

Apple should be coming out with a fix for this sometime

Probably not. It only affects old versions of the operating system that Apple no longer supports.

#11 User is offline   Cathrynt 

  • Pip
  • Group: Members
  • Posts: 8
  • Joined: 2021-October-13

Posted 2021-October-15, 10:46

As you know, on 30 September 2021, an old SSL root certificate expired, preventing players from running the BBO App on older iPhones/iPads.

Note that this issue is not unique to BBO, it also affects other 260 million apps and websites that use Let’s Encrypt certificates.

To run the BBO App normally on an old Apple device, you’ll need to install a new Let’s Encrypt SSL root certificate. Luckily, it is quite easy to do so:

• Visit https://letsencrypt..../isrgrootx1.pem using Safari on your iOS 9 device, to automatically install the new certificate (note: Safari only!)
• When Safari downloads the certificate, it will recognize it as a configuration profile and open it in the Settings app
• From there you just push Install, enter your passcode, push Install again, and push Install a third time on the dialog that pops up.

BBO App should run normally after installing the certificate.

Note: If you deleted the BBO app, click on PURCHASED entry at the bottom menu (AppStore), and search for “BBO” there. AppStore will install a BBO app version compatible with iOS 9.
I got this from BBO support who have been very proactive in trying toi help me gain access on my IPAD .
I dod hte above and it did not work - still had same probelm -
However after installing the new root above . I then went to the Ap store - when I tried BBO for IPAD I could not access it but I also had the option to go to the Iphone AP . Under I phone Ap I was able to reload BBO on the IPAD and its working !! - this might help others . Goood luck
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users